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Adobe InDesign 2023 is the premiere layout tool for a variety of exports:  print publications (paper books, catalogs, 

posters, brochures, …), digital contents (graphical user 
interfaces, digital publications, animations, drawings, 
interactive PDFs…), and others (bus wraps, van decals, 
billboards…).  It has sophisticated layout and image-
editing (and image animation) capabilities.  InDesign 
enables high level control of layouts (typography, font), 
still visuals (imagery), multimedia (art, video, audio, 
interactivity, animated characters), and other elements.   
 
Also, Adobe offers a range of free and paid templates for 
various file formats (through Adobe Stock).  [Read the 
fine print on the licensure!  Stay legal!  Stay legit!  There 
are free templates, too.]   
 

This technology is linked to the Adobe Creative Cloud library objects.  It is conceptualized as a design tool to be used in a 
connected way to the WWW and Internet, so there are online sharing capabilities (with built-in critique capabilities), and 
there are ways to publish to the cloud with randomly-generated links to view and experience the contents.  The online 
versions of publications can feature more interactive contents than the stand-alone interactive PDF.   
 
Adobe InDesign (2023) has various new features.  The Adobe MAX conference in Oct. 2022 focused on various keyboard 
shortcuts [Edit -> Keyboard Shortcuts] and scripts (short macros that enable different speedy visual image editing 
features).  To access scripts, go to Windows (in menu) -> Utilities -> Scripts.  Some are built in to the tool; others may be 
downloaded from various sites on the Internet.   
 
To access various scripts quickly, go to Quick Apply (CTRL + enter) and then conduct your searches.  Be sure that the 
object or objects that you are trying to change highlighted, then search for scripts using “s:” and then the keywords to 
find the scripts.   
 
To harness automation, go to Object Style and create various nested styles that will be applied sequentially to various 
types of text frames.   
 
Getting started.  The Essentials workspace is the simplest (especially for those who get distracted by having too many 
options available).   
 
• In-tool creation:  You can create contents on-the-fly by starting up InDesign, setting up the parameters of a file, 
getting your master set up, and creating contents.   
• Building off a template:  Or you can open a template and start building from that (and replacing placeholder 
visuals and text).   
• Artworks, videos, audio, animations, texts, data visualizations…:   And you can pre-create digital artworks 
(visuals, video, audio, animations) and texts…and place these objects into your file (or you can create the artworks and 
texts simultaneously to the layout design) in InDesign  
 
There are numerous right ways to start, continue, and complete the work.  People all have their own workflows that 
work for them.   
 
General Schedule 
 
Hour 1:    
Introduction to the Adobe InDesign workspaces (and selection of the types)    

Figure 1.  A Screenshot of Some Available Templates from Adobe Stock 
(some free, some w/ cost)  
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• Start screen and workspace  
Setting up preferences [Edit -> Preferences]  
Finding templates online through Adobe Stock (from within the app)  
Starting a new file (for print, web, mobile, and tablet) 
• Sizing of files [iPad Pro at 2732 x 2048 px; web 1920 at 1920 x 1080 px; letter size 8.5 x 11”; artwork; tabloid 
format for student newspapers, and others]   
o The measures are in pixels, points, picas (1/6 of an inch as a typographic unit), inches, millimeters, centimeters, 
ciceros, agates, and pixels (to enable precision and familiarity based on your preferences)   
 

 
 
• Setting up the master file [purpose of a master, recurring objects, pagination, A-master, blank, B-master] [Type -
> Insert Special Character -> Markers -> Current Page Number]  [Ctrl + shift + click to unlock text frames made in the 
master]  
o Go to the Pages panel to the right.  Expand to view the A-Master.   
 

 
  
To avoid using the styles in the master, highlight a page and click on the [None] to remove the formatting for that page 
(or sequence of pages).   
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Using layout grids, using pull-out guides  
Using the frame tool (as placeholders):  rectangle, ellipse, polygon (and free-form shaping); fitting images in different 
ways (to the frame with a right-click on the image, dragged within the frame using the direct select tool, and others)  
 

 
 
Placing content (File -> Place; Drag and Drop; placing with the placement gun; moving with the content grabber; fitting 
visual content to frame; using auto text-flow among linked frames OR using the “placement gun” to drop in other 
locales)  
• Imagery (every digital type possible except .raw) and video  
o Anchoring an object frame in a location in a text frame through inline placement (to move with the text even 
with variant and “reflowable” output)   
o Digital imagery placed in InDesign may be edited with Illustrator, InDesign, Photoshop, Firefox web browser, 
Google Chrome web browser, Microsoft PowerPoint, MS Visio, MS Word, and other tools  
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• To make animations in InDesign, one has to be in the Digital Publishing workspace.   

 

 
 
Click on an object to activate its properties panel.  Select the “Animation” tab, and select from the various dropdown 
motions that are available.  You will be asked to define the motion path and other factors.  
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• Alt-texting imagery for accessibility.  To ensure accessibility of imagery in InDesign, highlight the image by 
clicking on it and activating it.  Right-click it.  A menu will open.   

 

 
 
Select Object Export Options.  Put in custom text.  Or choose the source for the alt-texting.   
 
A window will open to ensure that enables you to input alternative text or to indicate where you want to alt-text to 
auto-populate from.   
 
Usually, it is better to emplace the accessibility elements at the design level…and then test in the finalized version.   
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• Can have an object anchored now outside a text (so it is not dependent on the spatial relationship to the text); 
can use the blue handle to anchor object outside of the text and in the columnar whitespace  [Object -> Anchored 
Object -> Options]  
o Image frames:  handles to scale, blue box for inline graphic, yellow box to activate live corners (shift key and can 
edit corner separate from other three corners)  
o AI (artificial intelligence) and content-aware fit  
• Text (serif and sans serif font families)  
o Overset text and flowing text across frames  
o Text sizing (ctrl + shift + >; ctrl + shift + <) 
o Text wrapping  
o Viewing linked text frames [View -> Extras -> Show Text Threads]  
• Locking and unlocking items  
Properties panels (context-sensitive to the activated object)  
Using rules (for layout and positioning)   
Aligning multiple objects  
Setting up smart objects (and their capabilities in the object panels)  
User-based CC libraries across Adobe Creative Cloud applications  
Access to Adobe Stock resources (free and w/ subscription or limited use cost)  
 
Hour 2:   
 
Limited Optional Topics as Time Allows:   
 
• Layers and how these generally work  
 
• Special effects (fx) related to imagery  
o Object-based stylesheet to apply styles to other objects  
o fx drag and droppable  
o Window -> effects  
 
o Tinting a grayscale image 
 
o Eyedroppers to copy effects (beyond just grabbing colors)   
 
• Gridifying an image (using a masking approach) 
o Paste an image in a frame  
o Select a shape.   
o Draw the shape over the image.   
o While holding down the left mouse button, use the ↑ (up arrow key) or the ↓ (down arrow key) to define the 
numbers of rows or columns in the grid.   
o Object Path -> Make Compound Path -> CTRL + Alt + V  
o Ctrl + x to hide object (photo in background)  (Try this video, too.) 
 
• Using clipping masks  
o [Create outlines (CTRL + shift + O)] or [Type Menu -> Create Outlines]  
o Paths / held together as compound paths; can break apart by releasing  
o Applying effects to the respective visual (masks about showing and hiding)  
o Can use words and shapes and such as custom frames (and showing portions of an image in the background)   
 
• Outputting book (created from Workspace -> Book)  

Figure 2.  An Image of “Footprints” 
Easter Egg in the Path Tool  

https://youtu.be/qH3EjcLafRw
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• Customized stylesheets to enable changes throughout similar objects with one change (cells, character, object, 
paragraph, table) [Window -> Styles]; nested styles   
 
• Fillable PDF forms [Window -> Interactive -> Buttons & Forms, enabling text fields on click] 
 
• Defining the Color Space (CMYK, RGB, HSB, others)  
o Color theme tool / image color swatching  
o Eyedropper tool  
 
 

 
 
• “Preflight” (proof or test) of project file (.indd) and proofing a document for output (and link checks) (Tip:  Do 
not change the names of your images or their locations in respective folders.  If sharing an InDesign project with others, 
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send the whole zipped folder of everything in order…so that the connections hold…and the quality of the editable 
project document is preserved.)   
o A less formal test involves selecting all and making sure that there are not stray objects on the artboard…or the 
pasteboard (off to the side)…although these latter draft / work objects do not usually export out  
 
• Publishing online (html5) 
o Page transitions  
 
• Social sharing for review in-tool  
• History of document (CTRL + About InDesign)  
   
 
The Liquid Layout feature enables rules-based re-layout of content in an intelligent way to version the layout.   
 
The sequence is Layout -> Create Alternate Layout (or) Liquid Layout to set the preferences.   
 

 
 
 
 
 
Creating a custom .indd template  
 

1. Generally, templates do not seem to have a different file extension designation.  (There is not a dedicated 
“template” designation.)   

2. These files are just the .indd Document file types, or .indb Books file types.  [Book formats are empty files that 
can take as input the various parts of the book.  Otherwise, books are just .indd documents.] 

3. To make a basic template in InDesign, open the file type that you need, and put in all the various elements that 
are necessary in the template.   

4. It helps to “trial” the template for a period of time to see what other changes may be needed for a “consensus” 
template.   

5. Spell check everything.   
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6. Then, after all the various elements are edited and properly emplaced and labeled, the template may be 
“finalized” for the next while.   

7. Put “template” as part of the name somewhere, so its identity is known.   
8. If there are artworks and logos and icons that go with the template, ensure that they are in the proper spatial 

resolution and linked to the template in the same folder.   
 
Multilingual?  
 

 
 
 
QR Code Generator in InDesign  
 
Highlight the URL.  Copy it.  Unclick off of it.   
 
Go to Object in the menu.  Go to “Generate QR Code.”   
 
(See the screenshot below.)   
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What does a general work pipeline look like with InDesign?   
 

 
There are many other ways to work and other work pipelines, though, and some start from InDesign and create from 
there.  What works for you is the right way / are the right ways.   
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InDesign as Part of a Work Path:  It is helpful to think of Adobe InDesign as part of a work path.  As such, it can take as 
imports various digital and digitized files…and can then export the layouts into various formats.  Please see the table 
below.   
 

Importable Files (for Placement)  Exportable Files 
 
Place As  

 
 
 

 
Export As  
 

 
Save As / Save a Copy  
 

 
 
.indd (project file)  
Online HTML5 files  

 
About learning InDesign  
 
The digital workspace has various nuances and complexities.  The best way I can think of in learning in this space is to 
learn the basics and then acquire the learning piece-by-piece through watching videos, reading, and trying new things.  
This is a very safe space to explore (at least outside of actual projects).  It helps immensely to use actual low-risk projects 
for learning, too.   
 
Practice matters, or else you’ll get rusty-ish like I am on this tool.  It helps to work on actual projects that have to meet 
professional standards.  It also helps to work on a variety of digital content types.   
 
Note the importance of testing…for spelling, for grammar, for branching logic, for interactivity, and so on.  All 
functionalities should be tested for efficient and smooth functioning.   
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Presenter:      
 
Dr. Shalin Hai-Jew 
Instructional Designer, Researcher  
ITS, K-State  
shalin@ksu.edu 
 
 
 
 
 
 
Links for Digital Handout Download:   
 
http://www.k-state.edu/ID/IntroAdobeInDesign.docx  (MS Word download)  
 
http://www.k-state.edu/ID/IntroAdobeInDesign.pdf  (PDF download)   
 
 
 
 
 
 
 
 
 
Updated:  April 2023 
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