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“Intro to NVivo 12 Plus (on Windows)” 
 

 
 
Why Computer-Assisted Qualitative Data Analysis Software (CAQDAS)?  CAQDAS tools have come a long 
way.  They enable both traditional types of qualitative and mixed methods coding…as well as other 
computational capabilities like auto coding and machine learning.  NVivo 12 Plus enables the following:   
 
Traditional stuff:    

• Manual coding of textual data  
• Organization of code  
• Output of a manual or autocoded (or combination) codebook  

 
More contemporary stuff:    

• Inclusion and archival of multimedia contents (digital imagery, maps, audio, video, slideshows, 
PDF files, some mixed media, and others) (but need text-versions of multimedia in order to run 
queries and autocoding) (a structured, semi-structured and “unstructured” database)  

• Inclusion of traditional text files and data tables  
• Ability to ingest large amounts of interview data for analysis  
• Integration with Qualtrics and Survey Monkey and other third-party survey tools (with 

autocoding during the data download)   
• Integration with software citation programs (Mendeley and  others)   
• Ability to add classification sheets to “case nodes” (interview subjects) to label by attribute data 

for more complex (like compound) queries  
• Inclusion of any language representable by UTF-8 (Unicode character set used on the Web) but 

with one main base content language  
• Ability to set a base language (from a half-dozen world languages) and built-in stop-words lists 

and sentiment dictionaries and other features  
• Computer-enabled queries (text frequency counts, text searches, matrix queries, coding 

comparison, and others) of fairly large datasets (depends on the local machine processing and 
memory capabilities)   

• Complex mixed queries across types of information  



2 
 

• In-software human transcription (with light transcription aids)  
• Autocoding for sentiment (based on an internal coded non-consumptive sentiment dictionary 

but editable results)  
• Autocoding for topic modeling (theme extraction)  
• Autocoding by person (ego) or group (entity) (case code) 
• Autocoding by “range code” (collections of paragraphs to particular nodes)  
• Autocoding by existing pattern (to emulate a unique human coding “fist”)  
• Extraction of social media platform data (Twitter, Facebook, YouTube, and the Web)  
• Ability to team-code a project (with project import / export / sharing…or locally hosted server-

based NVivo)  
• Ability to calculate Cohen’s Kappa / Kappa coefficient (for similarity analysis with multiple-coder 

approaches /  team coding)  
• Ability to download a codebook  
• Easy export of data tables and data visualizations  
• Plenty of data visualizations (intensity matrices, maps, sunburst diagrams, treemaps, 

dendrograms, word trees, geographical maps, and others)   
• Sociogram visualizations  
• Project event logging, and others   

 

 
 
Of special note are new features in NVivo 12:   
 

• Qualitative cross-tab analysis (of codes, attributes, and cases)   
• Import/export of quantitative data files with SPSS (IBM’s Statistical Package for the Social 

Sciences)  
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• A faster way to export a codebook from the nodes view  
 

 
 
 

Some Quick Ways to Get Started 
 
General Steps:   
 

1. Conceptualize the research design.  Identify the theories, theoretical frameworks, models, or 
other elements that influence the research design.   

2. Acquire the proper permissions to do the research.   
3. Conduct a review of the literature.  (*  NVivo can be brought on to the project at any time, but 

this may be a particularly natural entry point.)   
4. Conduct the research.  Follow through on the research methodology.   
5. Maintain a research journal.   
6. Capture the data.  Store a pristine version of the data.   
7. Clean the data.   
8. If the data is multimedia data, render that into text format.  Capture all relevant information 

from the data.   
9. Code the data—based on the research design. Apply a priori coding if required.  Apply emergent 

coding if required.  Or combine the coding approaches.   
10. Conduct statistical analyses on the data.   
11. Export a codebook.   
12. Export research journal.   
13. Export memos.   
14. Export data visualizations.   
15. Write up the research.   
16. Finalize materials for presentation.   
17. Archive the .nvp files per the requirements of the research.   
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Project Sizes:  Consider project sizes…and how askable questions may be… 
 

 
 

• Smaller projects can always be combined to ask particular complex and nuanced questions.   
• Organizing information into smaller projects (which are properly named) may help with 

organization.   
• Those who are clear about what information is where can combine the various parts of a project 

and maintain coherence, but new researchers may find this much more challenging.   
• Larger projects are slower to process and take up more memory.   

 
 
Keep copies of raw data and files used.   Export downloaded data from social media platforms and 
bibliography software.  Export data visualizations.  NVivo is a proprietary software, and one would lose 
access to the data and coding if they lose access to the software.   
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Former Notes re: NVivo 10 and NVivo 11  
 

 
 
Tip re: Navigating the NVivo 10 Workspace:  Start at the bottom left of the Navigation View and go 
clockwise from general to specific…to navigate to a particular file to edit and code in the Detail View. To 
navigate to resources, define the type, identify the folder, choose the target file from the list, and work 
on files in the Detail View.  The Find Bar enables a way to cut to the chase if an individual is aware of the 
source file / folder / code name.  
 

Some Function-Based Paths through NVivo 10 
1.  Starting an NVivo Project  
Start NVivo - < New Project -> Title / Description / File Location -> Write User Actions to Project Event 
Log (if individual or group project)  
          Event logs may not be captured retroactively.  They may be started at the beginning of a project 
and at any point thereafter but will only start being captured as a text file once this feature is turned 
on.   
         (There is an automated reminder to save the project every 15 minutes.  It is a good idea to save 
at every juncture.)   
         An NVivo project file extension is .nvp for one created from NVivo on Windows and .nvpx for one 
created from NVivo on Mac.   
2.  Saving a Copy of a Project (for backup on a remote server and / or memory in another physical 
space)  
File -> Manage -> Copy Project  
[Project Recovery File:  NVivo has a recovery file.  To see if this is set up, go to File -> (Application) 
Option(s) -> Project Recover (tab at the top right of the window) -> Set how often a project recovery 
file is saved to the Documents folder in the C drive -> Click “Okay” to save.]   
3.  Putting in the Software Key  
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File -> Help -> Product Activation (or License Renewal) -> Activate  
(The actual sequence changes depending on whether the individual had a trial license, an annual site 
license key, an eternal license, or some other license key.)   
4.  32-Bit or 64-bit System (on Windows OS) / OS X 10.7.5 Lion and Later for Macs (on OS X) 
Start –> Right-click “Computer” -> Properties (System -> System Type)  
 
(On the Mac, there is only one native NVivo version, which requires that a machine be at a certain 
contemporary OS X 10.7.5 Lion and later, including Mountain Lion, Mavericks, Yosemite, etc.  NVivo 
10 / 11 for Mac is not supported on an iOS device or the iPhone or iPad.)   
5.  Accessing the Event Log as a Text File (if activated; not available retroactively; highly advisable 
for team-coded projects)  
File -> Info -> Open Project Event Log  
6.  Ingesting Contents into NVivo   
Click on Sources in the Navigation View.  Click into the Select Folder or Region.   

• Drag-and-drop acceptable files into the proper folder.   
• Click on the External Data tab.  Click on the file type.  Import from…(a full folder of files) (a 

single file).   
7.  Coding Text (including interview transcripts and field notes) 
Once Sources have been uploaded, in Navigation View, go to Sources.  Click on the Folder with the 
Sources.  In the List View, go to the appropriate file.  Double-click on the file to open it.  In the Detail 
View, highlight the text, and code to an existing node (or a new one).   
8.  Coding Audio / Video  
Access the Audio or Video file per the steps in “Coding Text” (directly above).  Above the waveform or 
video timeline, click on “Click to edit.”  Click on the Audio or Video visual to start the multimedia file 
playing.   

• Drag from the waveform or timeline to the Timespan cell and right click, and go to “Assign 
Timespan to Rows” for the computerized placement of the time span.   

• In the Content column, type in the transcript or other notes.  (Or pay to have the audio or 
video transcribed. Transcripts may be imported from Ribbon -> Import -> Browse…)   

• To code the related text, highlight the text in the Timespan and / or Content columns, and 
code to the selected (or new) node.  (Note that text in a transcript is not automatically 
coded.)   

9.  Coding an Image 
Access the Image file per the steps in “#7.  Coding Text.”   
Use the mouse cursor to highlight a section of the visual, and type notes in the Content area to the 
right of the image.   
10.  Classifications (source / node / relationship types)  
In Navigation View, click on Classifications (at the lower left). Three folders will be identified in the 
Classifications area:   

• Source Classifications:  This section offers metadata on Sources that are ingested through 
third-party reference tools (Mendeley, Refworks, Zotero)—if those tools enable the capturing 
of source metadata (like DOI, call numbers, and others).  There are a wide range of built-in 
source classification types.  Source typing may be applied during the ingestion of sources into 
the NVivo project.   

• Node Classifications:  Node Classifications refer to certain types of “case nodes”.  Built-in 
node classification types include Person or Organization, which are both types of entities.  
Case nodes enable the addition of additional classifying information based on “classification 
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sheets” linked to each node.  These classifications enable different ways of structuring the 
node information for analysis (usually on matrices).   

• Relationship Types:  In Relationship Types, this enables the defining of relationship types 
(direction and text-described type).  For example, text phrasing for types of relationships may 
be sequential (precursor to, post-, etc.), causal (leads to, prevents), and others.   

11.  Applying Classifications to Ingested Sources  
Highlight relevant ingested sources in the List View.  
Ribbon -> Home tab -> Properties (in item) -> Dropdown Menu (selection of pre-made classifications 
to apply)  
12.  Revising Classification Sheets: 
To revise a linked classification sheet linked to a particular type of classification… 
Classification (in Navigation View) -> Source / Node Classifications folder ->  Right-click on Attribute -> 
Attribute Properties window -> Revise “General” and revise “Values” to set parameters of the 
Classification Sheet attributes  
13.  Data Queries (all done around textual information, so all multimedia has to be rendered in a 
text version by transcribing / notetaking / annotation and coding) 
In the Ribbon, go to Query tab -> Query Wizard.   
In the Ribbon, go to Query tab -> Text Search (word and phrase contexts) / Word Frequency (text 
summarization) / Coding / Matrix Coding / Coding Comparison (interrater reliability) / Compound / 
Group …   
14.  Data Visualizations  
In NVivo, data (beyond their original forms) is shown as table data, matrices, data visualizations 
(dendrograms, word trees, word clouds, treemaps, and others), and locational maps.     
Different types of visualizations may be made based on the particular data (and the particular query 
sequence).   
15.  Creating a Codebook on NVivo  
Ribbon -> Explore -> New Report -> From a view… -> Node -> Selected Fields -> Node Classification 
Name / Node Classification Description …  (A codebook may include a wide variety of other 
information, too, but a basic codebook involves the coding name and the descriptors. These should 
be edited thoroughly before a finalized codebook is output to describe the data analysis 
methodology.)   
16.  Interrater Comparison (Cohen’s Kappa / interrater reliability)  
In the Ribbon, go to Query Tab -> Coding Comparison ->  (User group A vs. User group B)…   
17.  Creating Models  
“Models” are conceptualized as 2D node-link diagrams.  These may be manually drawn and labeled.  
These may be created by any combination of objects in NVivo (sources, nodes, etc.)   
Ribbon -> Explore -> New Model …   
(using contents and ideas to draw 2D node-link diagrams as parsimonious models to represent 
findings)  
18.  Creating a New Relationship Type  
Ribbon -> Create -> Classifications -> Relationship Type  
19.  Creating and Applying a Relationship Node  
Ribbon -> Create -> Nodes area -> Relationship (direction, type) -> From / To (for dyadic relationships 
between objects)   
20.  Creating Sets (with Objects)  
List View -> Highlight Nodes / Articles / Objects -> Right Click -> Add to Set -> Define Set  
21.  Creating Reports 
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Ribbon -> Explore -> New Report (wizard) …  (for codebooks and other contents)   
Others…    There are other possible paths, but these are some of the basics.   
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PRIOR VERSION:  Intro to NVivo 11 Plus (with Highlights of Some New Features) 

 

 
 
A Draft Summary of New Features for September 29, 2015 Rollout (http://newnvivo.com) (based on a 
QSR International webinar)  

• A new graphical user interface (GUI) for NVivo 11 for Windows modeled after Microsoft Office 
2013 look-and-feel (“minimalist, flat design, crisp edges, clean fonts”); new Start Screen and 
Backstage View; re-working some 250 icons; tested also for Windows 10 (and certified through a 
Microsoft certification process for compatibility)     

• Automation in autocoding (data handling) for unsupervised (1) theme extraction and (2) 
sentiment analysis   

• “NVivo for Teams” is the server version (including live collaboration, new security features, data 
backup features, scalability, and data sharing; can enable read-only access to some members—
based on role-based controls), not a hosted solution  

 
NVivo 11 for Windows  NVivo for Mac 
Three main product editions:  Starter (basic text), 
Pro (multiple data sources and team), and Plus 
(automated theme extraction, sentiment analysis, 
network analysis, and larger data set handling)  
 
(Project files between all three versions 
compatible, and may be multi-edited based on 
the level of access per licensure.)  

NCapture browser plug-in for Chrome for Social 
Media Data Extractions (from Twitter and 
Facebook APIs)  
 
Automated capture of EXIF data on scraped 
imagery (represented in thumbnail form but 
expandable and codable within NVivo) 

http://newnvivo.com/
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Automated concept extraction (enabling scaling 
up in data handling); inclusive of nouns and noun 
phrases for high dimensionality coding  
 
Enabled for English, French, Chinese, Japanese, 
Portuguese, and Spanish   

Image integration (digital images and diagrams 
as a data source)  
Ability to code regions (such as on maps or 
floorplans)  
Ability to code texts  

Light social network analysis (from data and social 
media data); egocentric (case-network or Twitter 
network sociogram types); vertex and network 
metrics; exportable as image files or to Pajek (.net 
files for this open-source and free network 
graphing tool)  

Highlighting coding stripes (interactive with the 
original coded text)  

Case comparisons (automated); autocoding of 
case nodes (through the Auto Code Assistant for 
Datasets for assigning of attribute values to cases 
and coding responses to individual cases / each 
respondent)  

 

A wider range of data queries  

Sentiment analysis (expressed in an intensity 
matrix or bar chart as very negative, moderately 
negative, moderately positive, and very positive; 
no neutral); apparently based on a built-in 
sentiment polarity dictionary or sentiment set  

Windows project file conversion capability  

Visual Modeling (node-link / vertex-edge graph 
modeling): Mind Map, Project Map, Concept 
Map, Explore Diagram, and Compare Diagram; 
can change focal points for on-the-fly re-mapping; 
can retrace steps (backwards and forwards) 
during the modeling process to see the evolution 
/ devolution of ideas   

Increased data visualization capabilities  

Can open NVivo 10 projects, but NVivo 10 cannot 
open NVivo 11 projects (and there may be some 
rare challenges with digital file transcoding)  

 

Improved word cloud styles; color palettes for 
dendrograms and other data visualizations  

 

Query refinement on-the-fly  
Easier relationship creation using the Quick 
Coding Bar 
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Selected Function-Based Paths through NVivo 11 Plus 
22.  Extracting Themes through Unsupervised Machine Learning  
Select source(s) (or nodes) for theme extraction in List View -> Analyze tab -> Auto Code Wizard -> 
Identify themes  -> resulting table of major themes and subthemes   
23.  Extracting Sentiment through Unsupervised Machine Learning  
Select source(s) or nodes for sentiment extraction in List View -> Analyze tab -> Auto Code Wizard -> 
Identify sentiment -> Model results in a matrix -> Model results in a bar chart  
          (Users can go into the underlying text that has been placed in the respective four sentiment 
categories and re-code them to a different sentiment category.  They can also choose to uncode text 
selections to exclude them from the sentiment consideration.  The sentiment analysis feature works 
with sentences and paragraphs best, so lists of words seem to be somewhat amenable to automated 
sentiment coding.)   
24.  Setting up a Sociogram (of case nodes or Twitter user account holders) 

• Select a case node -> Right-click on it -> Create Egocentric Sociogram (in the dropdown 
menu) … or  

• Open a Twitter dataset (captured using NCapture) -> Click “Twitter Sociogram” to the right of 
the table in the Detail View 

25.  Setting up Cases (as a new node type)  
• Ribbon -> Create tab -> Case (in the Nodes section)  
• Highlight ingested Documents -> Right-click -> Classify Cases from Dataset  
• Highlight ID column in ingested dataset -> Right-click -> Classify Cases from Dataset Wizard (4 

steps)  
26.  Richer Data Visualization Exploration  
Ribbon -> Explore Tab -> Maps -> Mind Map / Project Map / Concept Map  
Ribbon -> Explore Tab -> Visualizations -> Chart / Cluster Analysis / Tree Map / Comparison Diagram  
Ribbon -> Explore Tab -> Social Network Analysis -> Egocentric Sociogram / Network Sociogram  
 

 
 
27.  Data Query Adjustments On-the-Fly  
Ribbon -> Query -> … with a stable window in the Detail View for adjusting parameters of the 
respective data queries on-the-fly  
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Any Other Desired Demos  

(with remaining or post-event time)? 
 
 

Use Case #1:  Handling Surveys, Interviews, and Focus Group Data in NVivo 12 Plus (also 11 and 10)  
• NVivo enables particular ways to ingest survey, interview, and focus group data for efficient 

handling for coding.    
 

Use Case #2:  Team Projects and Team Coding 
• Codebook extraction  
• Source contents 
• Respective coder initials  
• Event log capturing (non-retroactive)  
• Pristine master file [with a priori codebook (if desired) and raw sources] or a master file with no 

contents and emergent codebooks and original raw sourcing…or some mix  
• Interrater reliability (Cohen’s Kappa or similarity/difference measure)  

 

Use Case #3:  Social Media Data Extractions and Analyses 
• Social media data extractions (via NCapture web browser add-on in IE or Google Chrome):   

o Twitter, Facebook, and YouTube 
o The Web and Internet (special note about .PDF printing of web pages as preferred over 

NCapture capture of a page because of size limitations)  
 
 

Other “Use Cases”?  
 
 

 

Some Additional Informational Resources 
 

Perpetual License or Subscription 
https://www.qsrinternational.com/nvivo/products 
 
A 14-day trial version is available.   
K-State’s site license for NVivo 11 Plus ended in April 2017.   
A subscription version of NVivo 12 Plus is now available (not just the access to Pro).   
 

More about Using NVivo 
 

Using NVivo:  An Unofficial and Unauthorized Primer (an open-access web book):   
http://scalar.usc.edu/works/using-nvivo-an-unofficial-and-unauthorized-primer/index  
 

https://www.qsrinternational.com/nvivo/products
http://scalar.usc.edu/works/using-nvivo-an-unofficial-and-unauthorized-primer/index

